Синтаксис встроенного языка 1с + видео обзор

Синтаксис встроенного языка 1с

Язык 1С очень похож на Бейсик. В 1С все ключевые слова можно писать по-русски.

Процедура РассчитатьНалог(Сотрудник, НекаяДата)

Простая процедура. После слова КонецПроцедуры точка с запятой не нужна, потому что это не оператор, а операторная скобка

Функция РассчитатьНалог(Сотрудник, НекаяДата)

Функция должна обязательно возвращать результат.

Если Оклад > 10000 Тогда
. Результат = «Нормально»;
Иначе
. Результат = «Плохо»;
КонецЕсли ;

Простое условие. После слова КонецЕсли должна быть точка с запятой, потому что так заканчивается оператор Если

Результат = ?(Оклад > 10000, «Нормально»,»Плохо»);Сокращенное Если.Если Оклад > 10000 Тогда
. Результат = «Нормально»;

ИначеЕсли Оклад > 5000 Тогда
. Результат = «Средне»;

Иначе
. Результат = «Плохо»;
КонецЕсли ;Множественное условие. Если первое условие не выполняется, то проверяется второе. Если второе условие не выполняется, то третье. Если ни одно из условий не выполняется то выполняется блок Иначе.

Если (Оклад > 10000) И (КодКатегории = 2) Тогда

В составном логическом выражении скобки обязательны!

Простой цикл Пока (цикл с неизвестным числом повторений). После слова КонецЦикла должна быть точка с запятой, потому что так заканчивается оператор ПокаДля Номер = 1 По 50 Цикл

Простой цикл Для (цикл с известным числом повторений).

Так оформляются метки и оператор безусловного перехода (GOTO). Чем меньше в вашей программе будет меток, тем лучше.Оператор Прервать производит досрочный выход из цикла. Управление передается на операторы после цикла.Перем Сотр;Явное объявление переменной.Номер = 1;Переменные можно не объявлять явно. При первом присвоении значения создается новая переменная.ФИО = Фамилия + » » + Имя + » » + Отчество;Сложение строк (конкатенация)НекаяДата = ‘01.01.2002’;Переменная, которая хранит дату.Перем глТекущийПользователь Экспорт;Объявление глобальной переменной в Глобальном модуле. Такие переменные доступны в любом месте конфигурации.

Обработка исключительных ситуаций.

Если во время выполнения операторов между словами Попытка и Исключение произошла ошибка, то управление передается на операторы между словами Исключение и КонецПопытки

Если ошибки не было, то управление передается на операторы после слова КонецПопытки.

Источник

Синтаксис встроенного языка 1с

Синтаксис встроенного языка 1сУчебник

Синтаксис встроенного языка 1сРассылка
Синтаксис встроенного языка 1сКурс лекций
Синтаксис встроенного языка 1сСтатьи
Синтаксис встроенного языка 1сПрограммы
Синтаксис встроенного языка 1сСсылки

Язык 1С очень похож на Бейсик. В 1С все ключевые слова можно писать по-русски.

Процедура РассчитатьНалог(Сотрудник, НекаяДата)

Простая процедура. После слова КонецПроцедуры точка с запятой не нужна, потому что это не оператор, а операторная скобка

Функция РассчитатьНалог(Сотрудник, НекаяДата)

Функция должна обязательно возвращать результат.

Если Оклад > 10000 Тогда
. Результат = «Жить можно»;
Иначе
. Результат = «Плохо»;
КонецЕсли ;

Простое условие. После слова КонецЕсли должна быть точка с запятой, потому что так заканчивается оператор Если

Результат = ?(Оклад > 10000, «Нормально»,»Плохо»);Сокращенное Если.Если Оклад > 10000 Тогда
. Результат = «Жить можно»;

ИначеЕсли Оклад > 5000 Тогда
. Результат = «Плохо»;

Иначе
. Результат = «Так жить нельзя»;
КонецЕсли ;Множественное условие. Если первое условие не выполняется, то проверяется второе. Если второе условие не выполняется, то третье. Если ни одно из условий не выполняется то выполняется блок Иначе.

Если (Оклад > 10000) И (КодКатегории = 2) Тогда

В составном логическом выражении скобки обязательны! (в версии 8.0 необязательны)

Простой цикл Пока (цикл с неизвестным числом повторений). После слова КонецЦикла должна быть точка с запятой, потому что так заканчивается оператор ПокаДля Номер = 1 По 50 Цикл

Простой цикл Для (цикл с известным числом повторений).
В версии 8.0 есть еще цикл Для Каждого (for each).

Так оформляются метки и оператор безусловного перехода (GOTO). Чем меньше в вашей программе будет меток, тем лучше.Оператор Прервать производит досрочный выход из цикла. Управление передается на операторы после цикла.Перем Сотр;Явное объявление переменной.Номер = 1;Переменные можно не объявлять явно. При первом присвоении значения создается новая переменная.ФИО = Фамилия + » » + Имя + » » + Отчество;Сложение строк (конкатенация)НекаяДата = ‘01.01.2002’;Переменная, которая хранит дату.Перем глТекущийПользователь Экспорт;Объявление глобальной переменной в Глобальном модуле. Такие переменные доступны в любом месте конфигурации.

Обработка исключительных ситуаций.

Если во время выполнения операторов между словами Попытка и Исключение произошла ошибка, то управление передается на операторы между словами Исключение и КонецПопытки

Если ошибки не было, то управление передается на операторы после слова КонецПопытки.

Источник

Встроенный язык

Встроенный язык является важной частью технологической платформы «1С:Предприятия 8», поскольку позволяет разработчику описывать собственные алгоритмы функционирования прикладного решения.

Встроенный язык имеет много общих черт с другими языками, такими как Pascal, Java Script, Basic, что облегчает его освоение начинающими разработчиками. Однако он не является прямым аналогом какого-либо из перечисленных языков.

Событийная ориентированность встроенного языка

Назначение встроенного языка в системе 1С:Предприятие определяется идеологией создания прикладных решений. Прикладные решения в 1С:Предприятии 8 не кодируются целиком. Большая часть прикладного решения создается разработчиком путем визуального конструирования — создания новых объектов конфигурации, задания их свойств, форм представления, взаимосвязей и пр. Встроенный язык используется лишь для того, чтобы определить поведение объектов прикладного решения, отличное от типового, и создать собственные алгоритмы обработки данных.

По этой причине модули, содержащие текст на встроенном языке, используются системой в конкретных, заранее известных ситуациях, которые могут возникнуть в процессе работы прикладного решения. Такие ситуации называются событиями. События могут быть связаны с функционированием объектов прикладного решения или с самим прикладным решением, как таковым.

Например, с функционированием объекта прикладного решения Справочник связан ряд событий, среди которых есть событие ПередЗаписью:

Синтаксис встроенного языка 1с

Это событие возникает непосредственно перед тем, как данные элемента справочника должны быть записаны в базу данных. Разработчик, используя встроенный язык, может описать алгоритм, который, например, будет проверять корректность данных, введенных пользователем. Разместив этот алгоритм в соответствующем модуле, разработчик обеспечит то, что каждый раз, как пользователь будет выполнять запись элемента справочника, система будет выполнять созданный разработчиком алгоритм и проверять, не забыл ли пользователь заполнить обязательные реквизиты справочника.

Таким образом можно сказать, что встроенный язык является скриптовым языком для программирования бизнес-логики, а использование модулей на встроенном языке является событийно-зависимым, т. е. выполнение модулей происходит при возникновении определенных событий в процессе функционирования прикладного решения.

Универсальные коллекции значений

Встроенный язык поддерживает работу с большим количеством разнообразных объектов. Безусловно, основную группу объектов составляют прикладные объекты, позволяющие описывать алгоритмы функционирования бизнес-логики.

Однако не менее важной группой являются объекты, предназначенные для хранения временных наборов данных в течение сеанса работы пользователя. Как правило, они служат для вспомогательного сбора, группировки, анализа и обработки информации:

Синтаксис встроенного языка 1с

Перечислим кратко их возможности:

Массив

Представляет собой пронумерованную коллекцию значений произвольного типа. К элементу массива можно обращаться по его индексу. В качестве элементов массива могут выступать, в частности, другие массивы. Это позволяет создавать многомерные массивы.

Структура

Представляет собой поименованную коллекцию, состоящую из пар ключ — значение. Ключ может быть только строковым, значение — произвольного типа. К элементу структуры можно обращаться по значению его ключа, т. е. по имени. Обычно используется для хранения небольшого количества значений, каждое из которых имеет некоторое уникальное имя.

Соответствие

Также как и структура, представляет собой коллекцию пар ключ — значение. Однако, в отличие от структуры, ключ может быть практически любого типа.

Список значений

Используется, как правило, для решения интерфейсных задач. Позволяет строить динамические наборы значений и манипулировать ими (добавлять, редактировать, удалять элементы, сортировать). Он может содержать значения любого типа, кроме того, в одном списке типы хранимых значений могут быть разными.

Например, список значений может использоваться для выбора конкретного документа из списка возможных документов, сформированного по сложному алгоритму.

Таблица значений

Таблица значений позволяет строить динамические наборы значений и манипулировать ими. Она может быть наполнена значениями любого типа, и в одной таблице типы хранимых значений могут быть разными.

Одним из примеров использования таблицы значений может служить организация представления в форме списка элементов справочника, отобранных по сложному алгоритму.

Дерево значений

Дерево значений представляет собой динамически формируемый набор значений любого типа, похожий на таблицу значений. В отличие от таблицы значений, строки дерева значений могут образовывать иерархические структуры: каждая строка дерева может иметь набор подчиненных строк, каждая из подчиненных строк, в свою очередь, также может иметь набор подчиненных строк и так далее. При этом поиск значений, сортировка, получение итогов могут осуществляться либо по текущему уровню иерархии, либо включая все подчиненные.

COMSafeArray

Представляет собой объектную оболочку над многомерным массивом SAFEARRAY из COM. Позволяет создавать и использовать SAFEARRAY для обмена данными между COM-объектами.

Фиксированный массив

Неизменяемый массив. Массив заполняется системой при инициализации объектов данного типа или разработчиком, с помощью конструктора.

Редактор текстов и модулей

Для создания и изменения текстов на встроенном языке разработчик может использовать редактор текста и модуля, обладающий удобными средствами создания, редактирования и синтаксической проверки модулей. Подробнее…

Источник

Описания синтаксиса языка программирования 1С 8.3 и 8.2

Язык программирования 1С — формальная знаковая система, предназначенная для записи компьютерных программ. Язык программирования определяет набор лексических, синтаксических и семантических правил, задающих внешний вид программы и действия, которые выполнит исполнитель (компьютер) под её управлением.

Синтаксис встроенного языка 1с

Платформа 1С Предприятие 8 имеет полноценный функционал для разработки собственных решений для разработчика. Главный инструмент разработки — это встроенный язык программирования 1С 8.3.

Язык программирования 1С не имеет названия, на официальных источниках он обозначен как «встроенный язык программирования».

На что похож язык программирования 1С

Встроенный язык программирования 1С — язык программирования, который используется для разработки приложения на базе платформы 1С Предприятие. Данный язык является предварительно компилируемым предметно-ориентированным языком высокого уровня. Язык более всего напоминает по синтаксису Visual Basic в сочетании с языком запросов T-SQL.

Создание новых классов программно в языке 1С 8.3 запрещено. Так как платформа 1С Предприятие специализирована для задач учета, состав классов заранее предопределен:

На основании типовых классов можно в конфигураторе создать любое количество подклассов, имеющих свои наборы. С помощью модулей менеджеров можно незначительно расширить функционал подкласса.

Сложный ли язык программирования 1С?

Вопрос достаточно спорный и относительный. Если рассматривать его относительно других языков, возможно, он покажется немного проще. Однако помимо самого программирования, Вам придется изучать предметную область — бухгалтерию, производство, налоговый учет и т.д., что делает в совокупности язык программирования 1С не таким простым, как может показаться с первого взгляда.

Если Вы имели до знакомства с 1C солидный опыт на других предметно-ориентированных языках программирования, Вам не составит труда разобраться и в тонкостях конфигурирования 1С 8.2, главное — желание. Всё что Вам нужно — найти хороший самоучитель по языку программированию 1С.

Русский синтаксис языка 1С

Интересной особенностью встроенного языка программирования 1С является двуязычный синтаксис команд: русский и английский. Русский язык программирования сильно удивляет новичков в сфере 1С программирования 8.2.

Сообщить ( «Привет, Мир!» ) ;

Если Вы начинаете изучать 1С программирование, рекомендуем наш бесплатный курс (не забудьте подписаться на YouTube — регулярно выходят новые видео):

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

Источник

Обучение программированию на 1С

Краткий обзор языка 1С

Язык 1С считается самым простым в изучении. Одно из его конкурентных преимуществ – возможность написания кода на русском, что значительно упрощает процесс его освоения. Хотя имеются и англоязычные варианты языка, предназначенные для внедрения на зарубежных предприятиях.

Программирование на 1С – создание алгоритма или программного кода, который позволяет пользователю без проблем работать в программном интерфейсе. Основной инструмент языка – команды (слова), которые в определённой последовательности создают общую функциональную оболочку программы. Команды бывают следующих видов:

3. Функции и процедуры;

Давайте разберём все их более детально.

Переменные

Допустим, имеется число 15. Это есть значение. Изначально оно нигде не сохраняется. Чтобы поместить её в информационную базу (ИБ) программы, необходимо выполнить сохранение в переменной, которая может именоваться хоть как, скажем, результат.

Переменная, которая относится к объекту 1С (поле справочника, допустим) и сохраняется в информационную базу – это реквизит. К любой переменной допускается присвоение разных типов данных: можно сначала присвоить тип «число», а затем – тип «строка». Но для реквизитов язык 1С предусматривает только один тип данных. Если указать в нём другое значение, допустим, вместо цифры – строку, то программа сначала попробует выполнить преобразование в цифровой формат. Если она не сможет это сделать, значение будет пустым.

Строка в стандартной переменной не ограничена по длине, в реквизите – чётко определена (но если требуется выставить неограниченную длину – устанавливается значение длины 0). Выполнять обращение к отдельным буквам в слове нельзя, но можно искать целые части (Лев(), Прав(), Сред()).

Сложные переменные

Давайте разберём пример, когда переменной присвоено несколько значений.

По виду массив аналогичен колонке в Excel. Каждая ячейка – переменная, которая имеет только одно название. Чтобы перейти к определённой ячейке, нужно ввести её номер.

Ячейки в 1С нумеруются с 0, а не с 1.

Аналогичные ячейки, но с возможностью добавления комментария.

Здесь программирование таблиц значений на 1С аналогично Excel – страничке со множеством строк и колонок.

Древовидная таблица, самый простой пример – окно конфигурации.

Строки программы

В конце любой строчки стоит «;», а комментарий добавляется после знака «//». Значение пишется в кавычках, например «14». Если требуется ввести кавычку в значении, её пишут два раза: «14 ««o»»!».

Значение может быть разделено на две строки, для этого язык 1С имеет знак «|»:

Для указания специфических символов используется объект: «Символы.»:

Операторы

Это средства, встроенные в язык 1С. Используются для создания простейшей последовательности.

Те или иные строки выполняются при наличии необходимых условий.

Строчки выполняются установленное количество раз или пока выполняется определённое условие.

Для прерывания цикла язык 1С имеет команду «Прервать». Для прерывания только одной итерации – «Продолжить».

Объекты

Любой объект в 1С полноценен, то есть ему могут присваиваться уникальные от остальных методы и данные.

Для создания объекта используется параметр «Новый».

Для создания объектов применяются менеджеры. Их называют в соответствии с ветками конфигурации: Документы, Справочники и т.д. Методы в менеджере можно расширять:

Собственные объекты конфигурации 1С неизменяемы.

Ошибки в 1С

Программирование на 1С отличается тем, что при написании программы не всегда понятно, появится ли ошибка при выполнении той или иной строчки. Так, если во внешней обработке ввести:

и открыть её в базе, где указанного справочника нет – возникнет ошибка.

Чтобы она не выскочила, можно применять такой алгоритм:

Если при выполнении кода между «Попытка» и «Исключение» будет ошибка, то выполнение остановится и программа перейдёт к строчке между «Исключение» и «КонецПопытки». Если ошибка не появится, строчки выполняться не будут.

Функция ОписаниеОшибки() запускается только между «Исключение» и «КонецПопытки» и выдаёт сведения о содержании возникшей ошибки.

Функции и Процедуры

Данные методы предназначены для одноимённого наименования сразу нескольких строчек. Затем, при написании этого названия в тексте кода, будет активирована соответствующая функция. Функции и процедуры – это стандартные методы и обработчики в языке 1С:

Отличие функции от процедуры в том, что последняя не может вернуть значение, которое было посчитано при выполнении данных строк:

Как программировать?

Программирование на 1С подразумевает использование модулей. Найдя подходящий модуль, можно приступать к написанию своего кода.

Пример для написания кода во внешней обработке:

Источник

Видео

Синтаксис языка 1С

Синтаксис языка 1С

1С с полного нуля /#2 знакомство с языком(синтаксисом) | для новичков |с нуля|#1С| бесплатные курсы|

1С с полного нуля /#2 знакомство с языком(синтаксисом) | для новичков |с нуля|#1С| бесплатные курсы|

Основные конструкции встроенного языка - Основы программирования 1С 8.3 - 1С:Учебный центр №1

Основные конструкции встроенного языка - Основы программирования 1С 8.3 - 1С:Учебный центр №1

1С Основные конструкции встроенного языка ч1

1С Основные конструкции встроенного языка  ч1

Обзор основных возможностей Синтакс-помощника 1С + краткий обзор использования Шаблонов

Обзор основных возможностей Синтакс-помощника 1С + краткий обзор использования Шаблонов

Встроенный язык программирования 1С:Предприятие - Урок 4

Встроенный язык программирования 1С:Предприятие - Урок 4

1с язык программирования синтаксис

1с язык программирования синтаксис

Марафон "Основы программирования в 1С". Урок 3. Встроенный язык

Марафон "Основы программирования в 1С". Урок 3. Встроенный язык

Регистры из встроенного языка 1С Предприятие 8.3

Регистры из встроенного языка 1С Предприятие 8.3

02 Основные конструкции встроенного языка Часть 1

02 Основные конструкции встроенного языка   Часть 1
Поделиться или сохранить к себе:
Добавить комментарий

Нажимая на кнопку "Отправить комментарий", я даю согласие на обработку персональных данных, принимаю Политику конфиденциальности и условия Пользовательского соглашения.